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Last time

Grammar of Graphics overview
Tableau and ggplot examples
In-class feedback survey

HW 2
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In-class feedback survey

Thank you!

Changes | can make:

Report common HW problems, clearer grading feedback
Practice exercises to do at home

Slides posted earlier, as PDFs

Speak louder
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Dissent between surveys:

» More vs. less class time on R code, examples, exercises
» More vs. less class discussion and interaction



Today

» Designing multi-part static graphics
(infographics, conference posters, etc.)
» Graphic Design elements:
text, graphics, color, typography, layout
» Graphic Design principles:
contrast, repetition, alignment, proximity
» Page layout and graph editing in Inkscape



Today

Follow along:

> PDFs of graphs in 05_GraphicDesign_STEM.pdf,
05_GraphicDesign_NonSTEM.pdf,
05_GraphicDesign_Biz.pdf

» Output example in 05_GraphicDesign_Layout.svg

(I made the back-to-back bar charts as in this Learning R tutorial)


https://learnr.wordpress.com/2009/09/24/ggplot2-back-to-back-bar-charts/

Examples of multi-part static graphics

Hannah Fairfield, Driving Shifts Into Reverse
Scientific American on Nobel prizes and on US health
Dorothy Gambrell, Missed Connections

xkcd, Dominant Players

Alberto Cairo's students’ projects
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They contain:

» Headings and body text

» Richly informative, complementary graphs
(not just data decoration)

» Annotations: interesting features; how to read the graph;
data sources


http://graphics8.nytimes.com/images/2010/05/02/business/02metrics/02metrics-popup-v3.jpg
http://www.scientificamerican.com/article/global-distribution-nobel-prize-reflect-shifts-modern-history/
http://www.scientificamerican.com/article/americans-get-fatter-drunker/
http://www.verysmallarray.com/?p=1538
http://flowingdata.com/2014/07/09/xkcd-dominant-players-in-chess-and-basketball/
http://www.thefunctionalart.com/2015/05/student-projects-and-future-of.html
http://www.thefunctionalart.com/2014/10/dont-call-yourself-infographics.html

Graphic Design elements

> Message

» Text: headings vs. body
> Images, symbols, graphs
» Color

> Typography

>

Layout



Text

Headings should structure your work. Make them short, informative,
and stand out for the reader’s first glance.

Body text should be readable, but smaller than headings so it
doesn’t overwhelm.

Headings and body should be set in contrasting types and sizes, to
make their different roles clear.



Graphics

For us, as statisticians. ..

» Graphics should support your message and inform the viewer,
not just draw attention

» Choose a graph that tells the story clearly, not just a default
choice (e.g. having spatial or temporal data doesn’t always call
for a map or timeline)

“Charts shouldn’t be about making the story more eye-catching, but
about communicating more efficiently—meaning, showing a pattern
in the data that would be too laborious to describe in prose.”
—Mike Bostock


http://www.perceptualedge.com/blog/?p=2121
https://www.reddit.com/r/dataisbeautiful/comments/3k3if4/hi_im_mike_bostock_creator_of_d3js_and_a_former/cuuossv

Color

Use a limited palette to support your structure and subject matter.

Check that they show up well on your final display:
paper? projector? variety of browsers and devices?

Again, Color Brewer is helpful


http://colorbrewer2.org/

Typography

Typeface categories:

Aa B b C C Sans serif font
AaBb C C Serif font
AaBbCc s

» Bold sans-serifs: good for headings
» Readable serifs: good for body text
» Script or decorative: best for careful limited use


https://en.wikipedia.org/wiki/Typeface

Typography

Limit yourself to a few contrasting fonts
(typeface size, weight, and style combinations)

Ways to contrast with typography:

> Size

Weight (regular vs. bold)
Structure, category, form
Direction
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Color



Layout

Grids are helpful. To avoid “dull” symmetry and add contrast, try:

» Rule of thirds
» Golden section

What grid layouts are common for these formats?

> Book
» Magazine
» Conference poster


https://en.wikipedia.org/wiki/Rule_of_thirds#Use
https://en.wikipedia.org/wiki/Golden_ratio#Geometry

Layout

Negative space or white space: don't fear it :)
Use it to reduce clutter and guide the viewer's eye

If things don't look great, try removing elements, not adding them



Graphic Design principles

Contrast
Repetition
Alignment
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Proximity

Principles and examples below are from Robin Williams,
The Non-Designer’s Design Book
(the whole book is a short, excellent read!)


http://amzn.to/1UE37wk

Proximity

Sally’s Psychic Services
Providing psychic support in Santa Fe
Contact lost loved ones, including pets. Get help
with important decisions. Find clarity in a
fog of unknowns.

Special rate for locals
sally@santafepsychic.com
santafepsychic.com
Phone consultations available 555-0978

This postcard is visually boring—nothing pulls your eyes in to the
body copy to take a look, except perhaps the two hearts. But just
as importantly, it takes a moment to find the critical information.

Sally’s Psychic Services
Providing psychic support in Santa Fe
Contact lost loved ones, including pets.

Get help with important decisions.
Find clarity in a fog of unknowns.

Sally@SantaFePsychic.com
SantaFePsychic.com

Special rate for locals!
PHONE CONSULTATION 555.0978



Proximity

Group related items together.
Proximity organizes related elements into coherent units.
Relate captions and headings with their graphics or text.

Use empty space to your advantage, as structure.



Alignment

6 Steps to Pie as Art

Preparation for creatin
Building the pie

Beautifying the pie a:
Cooking to perfectio
Presenting your creat
Eating pie art with jo

There is a nice, strong, invisible line along
type, and there is a nice strong line along t
Between the text and the image, howev
(empty) space, and the white space
you can see with the green dotted li
trapped, it pushes the two elements

ix Steps to Pie as Art

Preparation for creating
Building the pie

3 Beautifying the pie as art
Cooking to perfection
Presenting your creation

6 Eating pie art with friends

typeface
Transat Text Standard




Alignment

Ambrosia Sidney

Sock and Buskin

109 Friday $

Ambrosia Sidney

Sock and Buskin

Take a moment to decide which of the items

above should be grouped into closer proximity,

and which should be separated.

Sock and Buskin

Ambrosia Sidney

109 Friday Street
Penshurst, NM
(505) 555-1212

The elements on this
card look like they
were just thrown on
and stuck. Not one
of the elements has
any connection with
any other element
on the card.

Get in the habit of
drawing lines between
elements to determine
where the connections
are lacking.

By moving all the elements
over to the right and giving
them one alignment, the
information is instantly
more organized. (OFf course,
grouping the related
elements into closer
proximity is also critical.)

The text items now have
a common boundary;
this boundary connects
the elements.



Alignment

Nothing should be placed on the page arbitrarily. Every item should
have a visual connection with something else on the page.

Alignment creates unity and organizes the page.
Distant elements can still appear related if aligned to a bold line.

Centered text looks formal and sedate;
left-aligned or right-aligned is bolder and often works better.



Repetition

PIE JUST WANTS
TO BE SHARED

WORKSHOPSfDV PIE ARTISTS

L
SLAB PIES

When you have a large group for sharing,
consider a slab pie.
With a higher proportion of crust to filling
and easy slicing into squares, your crowd will love it.

A
JAR PIES

Make sweet pies in small wide-mouth jars,
top them with a lid and a ribbon,

and share the pie joy.
VAV
¥ \VAVAV.
ey L]
POP-TART PIES | u
Make a batch of pop-tart pies and freeze them. Al
Pop them into the toaster Y Pl
when someane drops by for tea. R
! | 1
\ i |-
typefaces ' —
ATD TAVERN PIE SHOP SANTA FE Transat Text Medium

Brioso Pro Regular and Italic
Heart Doodles %




Repetition

Repeat some aspect of the design throughout the entire piece.
Repetition creates unity and consistency as well as interest.

Find existing repetitions and strengthen them. ..
but not so far they overwhelm.



Contrast

ANOTHER NEWSLETTER!

Exciting Headline

Another Exciting
Headline

This is nice and neat, but there is not much that attracts
your eyes to it. If eyes are not attracted to a piece, few
will read it.

Ancther Newsletel!

Exciting Headline

Thrilling Subhead
Boring Subhead

Another Exciting
Headline

Can you feel how your eyes are drawn to this page, rather
than to the previous page?



Contrast

Contrast various elements of the piece to draw a reader’s eye into
the page.

Contrast creates interest and organizes information.
Make contrast dramatic! Small contrast leaves readers guessing.

Contrast your typefaces, colors, line thicknesses, use of space, etc.



Graphic design in practice

First, find your story or message.
Choose the right graphic forms to support it.

Next, sketch layout ideas on paper: set structure before style.
Rough sketching is OK: squiggles for text, X-ed out boxes for
images. Try many variations.

Then, choose a visual style: types, colors, non-chart images, etc.

Last, try out on computer.
See sketch examples from Alberto Cairo's students.


http://www.thefunctionalart.com/2015/03/how-my-class-projects-work-guidelines.html

Practice: sketching

On Blackboard are three PDF graphs | made for the
degrees-by-field-and-gender dataset:

» 05_GraphicDesign_STEM.pdf
» 05_GraphicDesign_NonSTEM.pdf
» 05_GraphicDesign_Biz.pdf

Sketch at least two different layout ideas.
How could you use contrast, repetition, alignment, proximity?



Practice: Inkscape

Inkscape is free and open source software for editing vector
graphics and laying out single-page documents.

Industry standard Adobe lllustrator is available on CMU campus
clusters, but expensive otherwise.

Also useful: Photoshop and GIMP for editing raster graphics
(including photos), or InDesign and Scribus for complex,
multi-page layouts.


https://inkscape.org/
http://www.cmu.edu/computing/software/all/illustrator/index.html
http://www.cmu.edu/computing/software/all/photoshop/index.html
http://www.gimp.org/
http://www.cmu.edu/computing/software/all/indesign/index.html
http://www.scribus.net/

Practice: layout in Inkscape

File > Document Properties to choose size

View > Grid to see a grid (and snap elements to it)

View > Snap to toggle snap-to-grid behavior

Drag from rulers on left and top to create guides for your layout
Add background boxes or rules (lines) for headings

File > Import to add my PDF graphs from R
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Practice: editing graphs and text in Inkscape

v

E: S key for selector tool to move elements, align graphs

: T key for text tool to create and edit text boxes;
click and drag before releasing to create a box with text wrap

v

: D key for dropper tool to select color from on-screen

v

» Text > Remove Manual Kerns on selected textbox if edited
text looks smushed together

» Add direct labels, change text colors, delete legends

» Fix negative numbers, add spaces in degree names

» Edit subplots’ title text (STEM and Non-STEM),
delete Business title text

> Add overall title, subtitle, body text, credits, data sources



Resources

» Cairo textbook DVD
» Robin Williams, The Non-Designer’s Design Book
» Lynda.com online tutorials (design principles, Adobe
[llustrator, etc.)—free access through CMU
» Inkscape tutorials
» lan Mitchell, “Authority or Cliche?”:
article on graphic vs. information design


http://amzn.to/1UE37wk
http://www.cmu.edu/lynda/
https://inkscape.org/en/learn/tutorials/

For next time

» We'll learn basic concepts of Interaction Design, how to apply
them to your visualizations, and how to implement them in
Shiny and D3.js

> Install Shiny R package and download D3.js if you want to
follow along

» Readings: Cairo Ch 9

» HW 3 (Grammar of Graphics) due Saturday at 5pm, through
Blackboard


http://shiny.rstudio.com/
http://d3js.org/

